MATLAB and SIMULINK
Tutorial for SYS SYS5100

TA: Omar Al-Buraiki  oalbu060@uottawa.ca
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All material here taken from Matlab help e

Create Functions in Files

Both scripts and functions allow you to reuse sequences of commands by storing them in program
files. Scripts are the simplest type of program, since they store commands exactly as you would
type them at the command line. Functions provide more flexibility, primarily because you can pass
input values and return output values.

For example, this function named fact computes the factorial of a number (n) and returns the result
().

function £ = fact(n)
f = prod(1:n);
end

This type of function must be defined within a file, not at the command line. Often, you store a
function in its own file. In that case, the best practice is to use the same name for the function and
the file (in this example, fact.m), since MATLAB® associates the program with the file name.
Save the file either in the current folder or in a folder on the MATLAB search path.

You can call the function from the command line, using the same syntax rules that apply to
functions installed with MATLAB. For instances, calculate the factorial of 5.

55
fact(x)
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Contents of Functions and Files

The body of a function can include valid MATLAB expressions, control flow statements,
comments, blank lines, and nested functions. Any variables that you create within a function are
stored within a workspace specific to that function, which is separate from the base workspace.

Program files can contain multiple functions. If the file contains only function definitions, the first
function is the main function, and is the function that MATLAB associates with the file name.
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Functions that follow the main function or script code are called local functions. Local functions
are only available within the file.

End Statements

Functions end with either an end statement, the end of the file, or the definition line for a local
function, whichever comes first. The end statement is required if:

Any function in the file contains a nested function (a function completely contained within its
parent).

The function is a local function within a function file, and any local function in the file uses
the end keyword.

The function is a local function within a script file.
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Simulink®

Create Simple Model

Model Overview for This Tutorial

You can use Simulink® to model a system and then simulate the dynamic behavior of that
system. The basic techniques you use to create the simple model in this tutorial are the same
techniques that you use for more complex models.

To create this simple model, you need four Simulink blocks. Blocks are the model elements that
define the mathematics of a system and provide input signals:

Sine Wave — Generate an input signal for the model.
Integrator — Process the input signal.
Bus Creator — Combine multiple signals into one signal.

Scope — Visualize and compare the input signal with the output signal.
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Simulating this model integrates a sine wave signal to a cosine signal and then displays the
result, along with the original signal, in a Scope window.



Open New Model in Simulink Editor
Use the Simulink Editor to build your models.

1. Start MATLAB®. From the MATLAB Toolstrip, click the Simulink button @A short
delay occurs the first time you open Simulink.
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2. Click the Blank Model template, and then click the Create Model button. The Simulink
Editor opens with a new block diagram.
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3. Select File > Save as. In the File name text box, enter a name for your model, For
example, simple_model.slx. Click Save.



Open Simulink Library Browser

From the Simulink Library Browser you can search for blocks to use in your model. Also, you
can create a new Simulink model, project, or Stateflow® chart.
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2. Setthe Library Browser to stay on top of the other desktop windows. On the Library Browser

toolbar, select the Stay on top button

Browse or Search for Specific Blocks

To browse through the block libraries, select a MathWorks® product and then a functional area
in the left pane. To search all of the available block libraries, enter a search term.

1. Search for a Sine Wave block. In the search box on the browser toolbar, enter sine, and then
press the Enter key. Simulink searches the libraries for blocks with sine in their name or
description, and then displays the blocks.
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2. Get detailed information about a block. Right-click a block, and then select Help for the
<block name>. The Help browser opens with the reference page for the block.

3. View block parameters. Right-click a block, and then select Block Parameters. The block

parameters dialog box opens.

Add Blocks to Model

You build models by dragging blocks from the Simulink Library Browser window to the
Simulink Editor or single-clicking your model and entering a search term.

To build the simple model, begin by copying blocks from the Simulink Library Browser to the

Simulink Editor.

1. In the left pane of Simulink Library Browser, select the Sources library.
2. From the right pane, select the Sine Wave block.
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3. Drag the Sine Wave block to the Simulink Editor. A copy of the Sine Wave block appears in

your model.
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4. Add a Scope block using this alternative procedure:

a. Click within the block diagram.

b. After the search icon appears, type scope, and then from the list, select Scope.
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5. Add the following blocks to your model using one of the approaches you used to add the
Sine Wave and Scope blocks.

Library
Continuous

Signal Routing

6. Your model should now have the blocks you need for the simple model.
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Move and Resize Blocks

Before you connect the blocks in your model, arrange the block inputs and outputs to make signal
connections as straightforward as possible.

1. Move the Scope block after the Bus Creator block output. You can either:
e Click and drag the block.

e Select the block, and then press the arrow keys on your keyboard.

2. Move the blocks until your model looks similar to the following figure.
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Block Connections

Most blocks have angle brackets on one or both sides. These angle brackets represent input and output
ports:

The > symbol pointing into a block is an input port.
The > symbol pointing out of a block is an output port.

Input port ) 1§ > Output port

Integratar

You connect block output ports to input ports with lines. The lines represent signals with time-varying
values.

Draw Signal Lines Between Blocks

Connect the blocks by drawing lines between output ports and input ports.

1. Position the cursor over the output port on the right side of the Sine Wave block.
The pointer changes to a cross hair (+).

2. Click, and then drag a line from the output port to the top input port of the Bus Creator block.
While holding down the mouse button, the connecting line appears as a red dotted arrow.
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3. Release the mouse button when the pointer is over the output port.
Simulink connects the blocks with a line and an arrow indicating the direction of signal flow.
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4. Connect the output port of the Integrator block to the bottom input port on the Bus Creator block using
a Ctrl key shortcut:

a. Select the Integrator block.

b. Press and hold the Ctrl key.

c. Click the Bus Creator block.

The Integrator block connects to the Bus Creator block with a signal line.
5. Connect the Bus Creator block to the Scope block by aligning ports:

a. Click and drag the Scope block until its input port is aligned with the Bus Creator output port. A
light blue line appears between the ports when the blocks line up horizontally.
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b. Release the mouse button. Ablue arrow appears as a suggested connection.
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c. Click the end of the blue arrow. The arrow changes to a black signal line connecting the blocks.
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Draw Branched Signal Lines
Your simple model is almost complete. To finish the model, connect the Sine Wave block to the Integrator

block. This connection is different from the other connections, which all connect output ports to input

ports.

1. Hold down the Ctrl key.

2. Position the cursor where you want to start a branch line. Click, and then drag the cursor away from

the line to form a dotted-red line segment.

g ex_simple_model - Simulink
File Edit View Dicplay

-8

P simple_model | @

W E e

B E

Diagram

His
5]

Simulation  Analysic

"G ® b

Model Browssr == | simple_madel

'

Code Tools Help

+id

®-» - e

-

N

¥

Sine Wave

+ 1

Flegrator

Scope

3. Drag the cursor to the Integrator input port, and then release the mouse button.
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The new line, called a branch line, carries the same signal that passes from the Sine Wave block to

the Bus Creator block.

4. Drag line segments to straighten and align with blocks. Your model is now complete.
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Define Configuration Parameters

Before you simulate the behavior of your model, you can modify the default values for the configuration
parameters. The configuration parameters include the type of numerical solver, start time, stop time, and

maximum step size.

1. From the Simulink Editor menu, select Simulation > Model Configuration Parameters. The
Configuration Parameters dialog box opens to the Solver pane.

Tip Alternatively, you can open the Model Configuration Parameters dialog box by clicking the parameters button

-

on the Simulink Editor toolbar.

2. Inthe Stop time field, enter 20. In the Max step size field, enter 0. 2. With the Solver parameter set

to auto, Simulink determines the best numerical solver for simulating your model.

Select:
Soher
Data Import/Export
b Optimization
Diagnostics
Hardware Implementation
Maodel Referencing
Simulation Target
» Code Generation

2

2% Configuration Parameters: simple_model/Configuration [Active)

* Commonly Used Parameters | = All Parameters

=N\ <

Sirmulation tirme

Start time: 0.0

Solver options

Slop time: 10.0

Type: Variable-step

T] Solver: |au1:o -

* additional options

Max EtEFI' size: auto

Min step size:  auto

Relztive tolerance:  le-3

Absolute tolerance:  auto

0K H Cancel H Help

| apply |

3. Click OK.
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Run Simulation
After you define the configuration parameters, you are ready to simulate your model.

1. From the Simulink Editor menu bar, select Simulation > Run.

The simulation runs, and then stops when it reaches the stop time specified in the Model
Configuration Parameters dialog box.

Tip Alternatively, you can control a simulation by clicking the Run simulation button @ and Pause simulation button l\-—/:l on the Simt
Observe Simulation Results
After simulating a model, you can view the simulation results in a Scope window.

1. Double-click the Scope block.

The Scope window opens and displays the simulation results. The plot shows a sine wave signal with
the resulting cosine wave signal.
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2. On the Scope window toolbar, click the Style button.

A Style dialog box opens with display options.
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3. Change the appearance of the display. For example, select white for the display color and axes
background color (icons with a pitcher).

4. Select black for the ticks, labels, and grid colors (icon with a paintbrush).

5. Change signal line colors for the Sine Wave to blue and the Integrator to red. To see your changes,
click OK or Apply.
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