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1. Software Description

The software being evaluated in this videotaped co-operative interface evaluation is Adobe Photoshop 7. Photoshop 7 creates, edits, and exports graphics to give graphic and Web designers, photographers, and video professionals an extra professional touch. It consists of the layer system, where users can add, edit and delete layers in any order or copy a layer over to a new image without having to redesign from scratch. It saves images in a variety of formats, removes backgrounds and other unwanted areas from photographs, blends image ends, etc... Photoshop comes with a big collection of distortion filters, allowing users to liquefy, emboss, sharpen, blur and more. In addition, a vast collection of brushes and artistic tools make the designing possibilities endless.

The workspace of Photoshop 7 is divided into 4 main sections (Picture 1 in Appendix). 

At the top level we can find the Menu Bar and Options Bar components. The Menu Bar contains menus for performing tasks. The menus are organized by topic. For example, the Layers menu contains commands for working with layers, whereas the Options Bar provides options for using a tool. 

At the right level we can find the Palette Well component. The Palette Well helps users monitor and modify images in their work area.

At the bottom level we can find the Status Bar component. The Status Bar gives extra information about icons and commands.

At the left level we can find the Toolbox component. The Toolbox holds tools for creating and editing images.

2. Summary of Procedures

· The software was evaluated on Monday January 31st, 2005. The software was already installed on the machine. The system information of the machine is the following:

· Operating System: 
Windows XP
· Version:

5.1 Service Pack 2
· System Architecture: CPU Family:15, Model:2, Stepping:4 with MMX, SSE Integer, SSE FP
· Built-in Memory:
495 MB
· Free Memory:
171 MB
· Memory Available to Photoshop: 449 MB
· Memory used by Photoshop: 50%
· Image cache levels:
4
· Use image cache for histograms: No
· Photoshop scratch has async I/O disabled
Scratch Volume(s): 
Startup, 37.19 GB , 27.86 GB free

· We asked the user to perform a list of tasks:


· We asked the user to start the program, and once it’s opened, we asked him to close all the Palette Wells on the workspace and to open them again from the standard menu.
· We then asked the user to open a colored image that we provided him and transform it to grayscale.
· The next task was to undo the work that was done on the picture.
· The user was then asked to open two images and copy one selection from an image to the other.
· A following step was to ‘blur’ a small part of the image.
· Then the user had to draw a rectangle filled with opaque green color.
· One of the tasks was to divide the picture into two parts, an upper one and a lower one, by a colorless line. (The user would be helped by the evaluator in case he had trouble performing this task: the evaluator will lead him to the extract tool, in the ‘Filter’ menu).
· The next task was to make a note attached on the image. 
· The user was then asked to write two texts with different colors.
· The user was asked to change the background color of the text.
· The user was asked to make the text in a curved shape.
· He was then asked to select and edit the text.
· Then to ‘Rasterize’ the image, and then to select and edit the text again.
· The last practical test was to transform a .jpg file into a .pdf file.
· The last tasks were mental tests where the user was asked to describe what he sees when he looks into the lasso tool icon, and into the crop tool icon. 
·  While the evaluation was running, the evaluators were asking the user to do the above mentioned tasks. The evaluators were also following up with questions depending on what the user did. We were guiding the user when he was stuck without being able to perform the task. 


The evaluators were constantly asking the user about what he is trying to do, and what he thinks that the system is doing, and why the actions that he took had the eventual consequences, where they expected? The user was also asked if the information given by the software about the tasks that he’s trying to do are enough and/or clear. 


We were dynamically taking advantage of the user’s unpredictable behavior that lead to many malfunctions that were not originally considered by the evaluators. 

The evaluation was not done to test the ability of the user to use the software, but rather the software’s ability to match the user’s need and perception. 

3. List of Malfunctions

Here is the list of the malfunctions found when reviewing the videotape:

· The user was mislead by the leads given to him to reopen the Palette Wells. He looked in the wrong place. 

· The user did not know what to do in order to transform the image into a grayscale image.

· Pop up, unclear questions while transforming the image into gray scale which did not make any sense to him.

· Advanced editing of the picture was impossible for an average user (splitting the picture into two parts).

· In ‘Filter’>‘extract’ menu, the information given was still not enough to perform the previous task.

· The fast edit list of the text does not give clear information about what each action does. 

· The conversion from jpg to pdf was not obvious to the user. He searched for a conversion tool in the menus.
· The conversion from jpg to pdf didn’t give the user enough feedback about the two types of encoding.
· The icon for the ‘blur’ tool (Picture A) gave the impression of generating waviness instead of blurriness.

· The design of the “lasso tool” icon (Picture B in the Appendix) does not convey any correct message.

· The design for the ‘crop’ tool (Picture C in the Appendix) does not convey any correct message to the user.

· The mouse rollover over icons only specified their names, no information about what the tool could do. 

· The user should click on the tool in order to see more info about it in the bottom of the software’s frame.

· Info feature (previous) was unnoticed by the user even when he was explicitly asked to search for it.

· Information is hard to find in help menu. 

4. Malfunction Analysis

1st Malfunction: Closing the palette wells and reopening them

· The first significant malfunction occurred while asking the user to close the Palette Wells and reopen them. It happened at the 3rd minute of the videotape. The user closed them, but couldn’t open them back. The first oral reply from the user was “Just a second”. Then he started looking in the menus in the Menu Bar. He opened ‘Edit’, ‘File’, then from the ‘View’ menu and backwards to the ‘Edit’ menu. He didn’t click on the ‘Window’ menu that is next to ‘View’, where these palettes are located. The user then asked us if he can have more time, which was given to him. He then re-clicked on the same menus that he already chose. After that he clicked on the ‘Window’ menu, and located one. Although all the palettes were in the same menu, he didn’t find any other one. Instead, he started looking in the Options Bar. After that we helped the user locate them in the Window menu. 

· Please refer to Picture 2 in the Appendix. It shows the elements of Window menu.

· Q1. How is the malfunction manifested?
The user opened ‘Window’ menu, found one palette only, and couldn’t find the other ones. It was noticed by the evaluator. 

Q2. At what stage in the interaction is it occurring?
It is occurring at the Goal Formation stage of the interaction since the user wanted to open them back, and he couldn’t complete this task.

Q3. At what level of the user interface is it occurring?
It is occurring at the Interaction Element level of the user interface since it occurs in the ‘Window’ menu.

Q4. Why is it occurring?
It’s occurring because the mental model of the user is different than the conceptual model of the designer. The mental model of the user tells him that the palettes are located in the ‘View’ menu, since it embodies what is seen on the workspace. Furthermore, in other popular software (MS Office Suite), the ‘Window’ menu indicates the different opened documents, which led the user to avoid looking in the ‘Window’ menu since he thought it contains references to the opened pictures.


· Changes would be most appropriate if we put the palette wells in the ‘View’ menu, and group all those located inside one frame into one title. Thus, the user would be able to determine the name of the Palette frame directly in the ‘View’ menu.

2nd Malfunction: Converting from JPG to PDF

· The second significant malfunction occurred while asking the user to convert a jpg image to a pdf. The malfunction occurred at the end of the videotape, around the 38th minute. When the user was converting the jpg image to pdf, a popup window appeared, requiring the user to choose one of the two types of encoding: ZIP and JPEG encoding. When the popup appeared, we asked the user what will happen if he chooses each of the encoding type. His answer was that ZIP will encode the picture as a zip, whereas JPEG as a picture. Then we asked him what would be the difference in the pdf file. His answer was that if he uses ZIP encoding, the pdf will be in a zip file, whereas if he uses JPEG, the picture will be directly in a pdf. We then asked him to try both encoding types, and see the difference.


· Please refer to Picture 3 in the Appendix. It shows the popup window for the two types of encoding.


· Q1. How is the malfunction manifested?
When the user was converting the image, the popup window appeared. It didn’t include any information regarding the two types of encoding. It was noticed by the user. After converting the image using both types, he didn’t see any difference between both of them. In addition, it didn’t turn out to be as he thought; he didn’t see any difference in the two pictures.

Q2. At what stage in the interaction is it occurring?
It is occurring at the Goal Formation stage of the interaction since while he was converting from jpg to pdf, the popup window appeared.

Q3. At what level of the user interface is it occurring?
It is occurring at the Conceptual Level of the user interface since the user thought that using ZIP encoding allows the pdf to be placed in a zip file.

Q4. Why is it occurring?
It’s occurring because here too the mental model of the user is different than the conceptual model of the designer. The user thought that ZIP encoding will put the pdf in a zip file, because he’s used to zipping and unzipping files. When he saw ZIP encoding, he related his understanding to the conversion in Photoshop and as a result, his thought like that.


· As for the changes, it would be more helpful if in the Popup window there was small information about each encoding type. By this it will help the user understand what each type does, and thus will choose the one that he really wants.



3rd Malfunction: Writing text
· This malfunction occurred when the user was asked to write text and make changes to it. This was during the 27th minute of the videotape. The user seemed a little lost trying to find something, his response to the question what are you trying to do was “I am searching for the pen”, he actually managed to find an icon that represents an ink pen, and he tried to use it to write text. The icon did match his mental model for writing, but it didn’t match the conceptual model of the developer because the pen icon had absolutely nothing to do with writing text. 

The user thought of using the note in order to write text. It took him a push from the evaluator before he was able to discover which icon is to perform text writing. 

· Please refer to Picture D in the Appendix. It shows the misleading pen icon (pen tool).

· Q1. How is the malfunction manifested?
The user wanted to write text and started looking for a pen shaped icon in order to write the text. The T shaped icon referring to text writing did not mean to him anything.


Q2. At what stage in the interaction is it occurring?
 When the user specifies the action (Action does not match the goal), since the user is trying to write with a different tool. 


Q3. At what level of the user interface is it occurring?
It is occurring at the Interaction Element level of the user interface since the user is misinterpreting the meaning of an icon.

Q4. Why is it occurring?
It is occurring because of several reasons, the first reason is that the designer relied on the familiarity of users with already existing icons in other popular software. The other reason is that the conceptual model of the designer for an icon that refers to text was totally different then the mental model of the user. 

· Changes could be done by making the T icons (text tool Picture E in the Appendix) a little more obvious that it refers to text, and by making the pen tool more appropriate to the actions that it actually refers to, and not confuse it with writing. 

4th Malfunction: Icon design

· This malfunction is related to the actual design of the icons. It was not found when actually performing a task, but it was found when the user was asked (videotape at the 20th minute) by the evaluators to express what he thinks an icon represents. In other words, does the icon really convey the correct message that it was meant to convey? 

For this malfunction several icons existed for discussion, but we have decided to choose just two of them, the “lasso” tool and the “crop” tool, which seemed to be the most frequently used by users. 

For the lasso tool, the user saw a rope, which was truly what the icon represented, and thought that this tool can be used to “connect pictures together”. The actual functionality of the tool is to select a random shape in the picture. 

For the “crop” tool, the user was not even able to understand the pictures on the icon; he could not make anything out of it. The user had absolutely no clue about the functionality of the tool by looking at the icon. 

· Please refer to Pictures B and C in the Appendix. They show the Lasso and Crop tools.

· Q1. How is the malfunction manifested?
This malfunction manifested as soon as the user tried to figure out the functionality of the tools by looking at the icons. 


Q2. At what stage in the interaction is it occurring?
The eventual malfunction in our case would occur when the user specifies the action (Action does not match the goal), since the user would be trying to use the tool in ways that it can’t be used. 


Q3. At what level of the user interface is it occurring?
It is occurring at the Interaction Element level of the user interface since the user is misinterpreting the meaning of an icon
 
Q4. Why is it occurring?
It is occurring because the conceptual design models of the icons by the developers were far off the mental model of the users. This is severely true because of the new functionalities that the Photoshop 7.0 is offering that put the developers in a position where they had to invent totally new and original icons without referring into any other popular software. 

· Changes can be done by referring to more users and asking their opinion. We as evaluators cannot in this situation propose any obvious solution; we can only point out to the way to the solution. In other words, the way to make the conceptual model of the developer closer to the mental model of the user. 

5. Assignment Organization
There was a small change for this assignment. The two users that were supposed to be videotaped (Michel Khoury and Samer Jabbour) couldn’t make it, so we chose Rami Lahoud, a computer literate, as our subject user. 
The Informed Consent Form was signed by both the evaluators and the user, and it is included in the report.
The videotape and the analysis of the malfunctions were performed by both evaluators. The written part of the report was as following:

1. Software Description ( Rabih )


2. Summary of Procedures

a. ( Rabih )

b. ( Hani )

c. ( Hani )


3. List of Malfunction ( Hani)

4. Malfunction Analysis

a. ( Rabih )

b. ( Rabih )

c. ( Hani )

d. ( Hani )


5. Assignment Organization ( Rabih )
The report was proofread by both evaluators.
Appendix

Picture 1 : Adobe Photoshop 7 workspace
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Picture 2 : ‘Window’ menu
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Picture 3 : Popup window of the JPG to PDF conversion
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Picture A : Blur Tool  [image: image4.png]



Picture B : Lasso Tool  [image: image5.png]



Picture C : Crop Tool  [image: image6.png]



Picture D : Pen Tool 
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Picture E : Text Tool 
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